Support

Phone

866-516-9497 x2

Email

support@designmaster.biz

Hours

9am to 5pm Eastern time

Remote Support

Support for Design Master Photometrics

Outdoor lighting design software for AutoCAD

Installation Instructions

Installing for a Single User

Installing for Multiple Users

Installing an Update

Documentation

User Manual

Tutorials

Video Tutorial

Change Log

List of changes to the software

System Requirements

AutoCAD 2007 or later, or BricsCAD V17 Pro or later, including

  • AutoCAD 2019
  • AutoCAD 2018
  • AutoCAD 2017
  • AutoCAD 2016
  • AutoCAD 2015
  • AutoCAD 2014
  • AutoCAD 2013
  • AutoCAD 2012
  • AutoCAD 2011
  • AutoCAD 2010
  • AutoCAD 2009
  • AutoCAD 2008
  • AutoCAD 2007
  • BricsCAD V18 Pro
  • BricsCAD V18 Platinum
  • BricsCAD V17 Pro
  • BricsCAD V17 Platinum

Windows 2000 or later

Supported on Old Release

AutoCAD 2004, AutoCAD 2005, and AutoCAD 2006 are supported, but on an older release of our software.

Download the installer for AutoCAD 2004, 2005, and 2006 here.

Not Supported

Any version of AutoCAD LT
AutoCAD R14, 2000, 2000i, and 2002
AutoCAD for Mac
BricsCAD V16 or earlier
BricsCAD V17 Classic
BricsCAD V18 Classic